스프링에서 sentry 적용하기

스프링 부트 프로젝트 sentry 적용

하지만 다음과 같이 exception이 났다.

해당 exception으로 찾아보니 현재 프로젝트는 스프링 부트 버전이 1.5.x 이었다. maven dependency를 확인해 보니 다음과 같다.

spring boot starter 의존성을 관리하는 부분때문에 기존의 logback 버전이 1.1.9로 매핑이 되어있었다. 다음과 같이 .1.2.3 버전을 추가하고 실행하니까 잘 동작한다!

<dependency>
  <groupId>ch.qos.logback</groupId>
  <artifactId>logback-core</artifactId>
  <version>1.2.3</version>
</dependency>
<dependency>
  <groupId>ch.qos.logback</groupId>
  <artifactId>logback-classic</artifactId>
  <version>1.2.3</version>
</dependency>

연관 포스트